Mega Links go to Blank page?

Mega Links go to Blank page?

Home Page Forums General Chat Mega Links go to Blank page?

This topic contains 11 replies, has 6 voices, and was last updated by Profile photo of Don_k Don_k 3 weeks, 2 days ago.

Viewing 12 posts - 1 through 12 (of 12 total)
Author Posts
Author Posts
Profile photo of Haven Hawkes

Haven Hawkes

said

Is anyone else having an issue with the mega links? I click on the download link and I am taken to a blank page.

November 18, 2017 at 8:08 pm
Profile photo of norbertz

norbertz

said

No, all good here. Try cleaning your cookies and junk files.

November 18, 2017 at 8:18 pm
Profile photo of Haven Hawkes

Haven Hawkes

said

found the issue, the Mega extension for firefox had to be deleted because I had to go back from firefox 57 to version 52 because 57 slows web browsing to slower than 1995 dial up.

November 18, 2017 at 8:24 pm
Profile photo of norbertz

norbertz

said

Edited below:

  • This reply was modified 4 weeks ago by Profile photo of norbertz norbertz.
November 18, 2017 at 8:27 pm
Profile photo of norbertz

norbertz

said

I don’t use the Mega extension because I’ve had issues in the past when Firefox updates.

November 18, 2017 at 8:29 pm
Profile photo of Ethiopia

Ethiopia

said

I keep an older version of Firefox installed on a different drive that just used for Mega downloads. My main browser sometimes has problems with them. I hate that Mega desktop crap but it’s useful with very large files.

November 18, 2017 at 10:37 pm
Profile photo of EvilMonkey

EvilMonkey

said

I use Mega Sync and swear by it, I stopped using Firefox when I got fed up them breaking the extensions I was using. I’ve used Chrome for the past 5 or 6 years with very few problems.

November 20, 2017 at 12:16 am
Profile photo of Don_k

Don_k

said

I’m looking into using the Brave Browser, it is made by the former Mozilla CEO before he got ousted for a Hillary backing SJW. FF57 is total crap and breaks 90% of published extensions.

November 20, 2017 at 4:36 am
Profile photo of nobdy

nobdy

said

I’m not personally impressed with Brave browser. The tabs keep erroring out on me and sometimes the whole browser just goes white and you can’t do anything but close it and reopen it, which losses all the tabs. And at the moment, I can’t even go to YouTube with it, as soon as the page loads, black error tab.

November 20, 2017 at 6:02 am
Profile photo of Don_k

Don_k

said

Thanks for the info. Were you using the 32Bit or 64Bit version of Brave?

November 20, 2017 at 7:04 am
Profile photo of nobdy

nobdy

said

@donk 64bit, but an update on the status of YouTubing for me, I reinstalled it (without uninstalling it so settings and everything were still there) and YouTube works again. I’m thinking that when it last updated, something happened during the update and messed something up, as I was updating my graphics drivers and not really paying attention to everything going on.

It’s not a terrible browser, but it has some… quirks.

November 20, 2017 at 8:57 am
Profile photo of Don_k

Don_k

said

I can live with some quirks, depends on how quirky they are.

November 23, 2017 at 3:56 am
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Copyright © 2013 ZoneGfx. All rights reserved.                                                            Follow: Twitter | Facebook | Pinterest